1. Welcome to AquaScaping World!

    Become a register member to get FULL SITE ACCESS AND BENEFITS.

    Join the ASW community now!

    Dismiss Notice

Water not cloudy, but lots of small particles

Discussion in 'General Aquascaping and Planted Tank Discussions' started by Al G. Begone, Nov 5, 2008.

  1. Al G. Begone

    Al G. Begone New Member

    Joined:
    Oct 22, 2008
    Likes Received:
    2
    Location:
    McKinney, Texas
    My 120 G has allot of tiny debris in the water.
    It is not cloudy and I am still doing 25% water changes every few days as of it's initial setup just over a couple of weeks ago.
    I have a Fluval FX5 connected to the bulkheads behind a corner overflow that only strains in from the top.
    The return is dual nozzle pointed generally the same direction but slightly different, towards the other side of the tank.
    I have prefilter in the top basket, course then fine foam stuff in the middle, and fine foam then bio media in the bottom.
    I don't know if it's because of the way the filtration is set up or because I have four insane yoyo loaches that continually mess with the substrate, or if its because of algae or what... allot of the debris I am seeing looks like very fine hairs about a 1/4 inch long floating around in the water.
    Or is it normal to not have perfectly clear water?
     
  2. Anti-Pjerrot

    Anti-Pjerrot New Member

    Joined:
    Feb 25, 2008
    Likes Received:
    1
    Location:
    Copenhagen, Denmark
    Its a very normal problem with filters that have not established fully yet. Try to give it some time, concentrate on feeding the plants right.
     

Share This Page

Sponsored link: