1. Welcome to AquaScaping World!

    Become a register member to get FULL SITE ACCESS AND BENEFITS.

    Join the ASW community now!

    Dismiss Notice

algae or not ??

Discussion in 'Algae' started by witkizz, Jan 16, 2010.

  1. witkizz

    witkizz New Member

    Joined:
    Dec 21, 2009
    Likes Received:
    0
    Location:
    indonesia
    hai i`ve set up my tank a weeks ago....a fill with some plants and wood...but something on my plants, my tank,...:eyeroll:
    this is the picture...

    ImageShack -

    can anybody help me ?? thanks
     
  2. Shadow

    Shadow Moderator Staff Member

    Joined:
    Aug 8, 2008
    Likes Received:
    228
    Location:
    Singapore
    what is that white-white thing? first time I see something like that :-?
     
  3. Carolina

    Carolina New Member

    Joined:
    Sep 24, 2008
    Likes Received:
    0
    Location:
    Atlanta GA
    I think dosing with KNO3 would get rid of it. How to dose KNO3 listed here.
     
  4. John N.

    John N. Administrator Staff Member

    Joined:
    Oct 30, 2007
    Likes Received:
    343
    Location:
    California
    Looks like a plant deficiency or more so than an algae problem. It also could be some bacterial fungus from your newly inserted driftwood, which I have seen happen on occassion.

    -John N.
     
  5. Carolina

    Carolina New Member

    Joined:
    Sep 24, 2008
    Likes Received:
    0
    Location:
    Atlanta GA
    So any progress in getting rid of the substance on the plant?
     

Share This Page

Sponsored link: